lc-kbswitch-9999.ebuild 609 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils leechcraft
  5. DESCRIPTION="Provides plugin- or tab-grained keyboard layout control"
  6. SLOT="0"
  7. KEYWORDS=""
  8. IUSE="debug"
  9. DEPEND="~app-leechcraft/lc-core-${PV}
  10. dev-qt/qtnetwork:5
  11. dev-qt/qtwidgets:5
  12. dev-qt/qtx11extras:5
  13. dev-qt/qtdeclarative:5[widgets]
  14. "
  15. RDEPEND="${DEPEND}
  16. x11-apps/setxkbmap
  17. "
  18. pkg_postinst() {
  19. elog "Consider installing the following for additional features:"
  20. optfeature "display layout indicator in LeechCraft tray" virtual/leechcraft-quark-sideprovider
  21. }