lc-musiczombie-9999.ebuild 554 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit leechcraft
  5. DESCRIPTION="MusicBrainz client plugin for LeechCraft"
  6. SLOT="0"
  7. KEYWORDS=""
  8. IUSE="debug acoustid"
  9. DEPEND="~app-leechcraft/lc-core-${PV}
  10. dev-qt/qtnetwork:5
  11. dev-qt/qtwidgets:5
  12. dev-qt/qtconcurrent:5
  13. dev-qt/qtnetwork:5
  14. dev-qt/qtxml:5
  15. acoustid? ( media-libs/chromaprint )"
  16. RDEPEND="${DEPEND}"
  17. src_configure() {
  18. local mycmakeargs=(
  19. -DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
  20. )
  21. cmake-utils_src_configure
  22. }