hstr-1.22-r1.ebuild 576 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Shell history suggest box"
  6. HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
  7. SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="Apache-2.0"
  10. KEYWORDS="amd64 x86"
  11. RDEPEND="sys-libs/ncurses:0="
  12. DEPEND="
  13. ${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS=( CONFIGURATION.md README.md )
  16. src_prepare() {
  17. default
  18. sed \
  19. -e 's:-O2::g' \
  20. -i src/Makefile.am || die
  21. eautoreconf
  22. }