bibletime-2.11.0.ebuild 962 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Qt Bible study application using the SWORD library"
  6. HOMEPAGE="http://www.bibletime.info/"
  7. SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. # bug 313657
  13. RESTRICT="test"
  14. RDEPEND="
  15. >=app-text/sword-1.7.0
  16. dev-cpp/clucene
  17. dev-qt/qtcore:5
  18. dev-qt/qtgui:5
  19. dev-qt/qtprintsupport:5
  20. dev-qt/qtwebchannel:5
  21. dev-qt/qtwebengine:5
  22. dev-qt/qtwidgets:5
  23. dev-qt/qtxml:5
  24. "
  25. DEPEND="${RDEPEND}
  26. dev-libs/boost
  27. dev-libs/icu:=
  28. dev-qt/linguist-tools:5
  29. dev-qt/qttest:5
  30. net-misc/curl
  31. sys-libs/zlib
  32. "
  33. DOCS=( ChangeLog README.md )
  34. src_prepare() {
  35. cmake-utils_src_prepare
  36. sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
  37. -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
  38. }