blogc-9999.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. if [[ ${PV} = *9999* ]]; then
  5. EGIT_REPO_URI="
  6. git://github.com/blogc/blogc.git
  7. https://github.com/blogc/blogc.git"
  8. inherit git-r3 autotools
  9. fi
  10. DESCRIPTION="A blog compiler"
  11. HOMEPAGE="https://blogc.rgm.io/"
  12. SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
  13. KEYWORDS="~amd64 ~x86"
  14. if [[ ${PV} = *9999* ]]; then
  15. SRC_URI=""
  16. KEYWORDS=""
  17. DEPEND="app-text/ronn"
  18. fi
  19. LICENSE="BSD"
  20. SLOT="0"
  21. IUSE="git httpd make test"
  22. RDEPEND="
  23. git? (
  24. dev-vcs/git )
  25. !dev-vcs/blogc-git-receiver
  26. !www-servers/blogc-runserver"
  27. DEPEND="${DEPEND}
  28. virtual/pkgconfig
  29. test? (
  30. git? ( dev-vcs/git )
  31. dev-util/cmocka )"
  32. src_prepare() {
  33. [[ ${PV} = *9999* ]] && eautoreconf
  34. eapply_user
  35. default
  36. }
  37. src_configure() {
  38. local myconf=""
  39. if [[ ${PV} = *9999* ]]; then
  40. myconf+="--enable-ronn"
  41. else
  42. myconf+="--disable-ronn"
  43. fi
  44. econf \
  45. $(use_enable test tests) \
  46. $(use_enable git git-receiver) \
  47. $(use_enable make make) \
  48. $(use_enable httpd runserver) \
  49. --disable-make-embedded \
  50. --disable-valgrind \
  51. ${myconf}
  52. }