cedilla-0.6.ebuild 697 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="UTF-8 to postscript converter"
  6. HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/"
  7. SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
  8. KEYWORDS="amd64 x86"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. IUSE=""
  12. DEPEND="dev-lisp/clisp"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/cedilla-gentoo-r1.patch
  16. }
  17. src_compile() {
  18. ./compile-cedilla || die "Compile failed."
  19. }
  20. src_install() {
  21. sed -i "s#${ED%/}##g" cedilla || die "sed failed"
  22. newman cedilla.man cedilla.1
  23. ./install-cedilla || die "Install failed."
  24. dodoc NEWS README
  25. }