enchant-1.6.0.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils autotools
  5. DESCRIPTION="Spellchecker wrapping library"
  6. HOMEPAGE="http://www.abisource.com/enchant/"
  7. SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  11. IUSE="aspell +hunspell static-libs zemberek"
  12. REQUIRED_USE="|| ( hunspell aspell zemberek )"
  13. COMMON_DEPENDS="
  14. dev-libs/glib:2
  15. aspell? ( app-text/aspell )
  16. hunspell? ( >=app-text/hunspell-1.2.1:0= )
  17. zemberek? ( dev-libs/dbus-glib )
  18. "
  19. RDEPEND="${COMMON_DEPENDS}
  20. zemberek? ( app-text/zemberek-server )
  21. "
  22. DEPEND="${COMMON_DEPENDS}
  23. virtual/pkgconfig
  24. "
  25. DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
  26. PATCHES=(
  27. # http://bugzilla.abisource.com/show_bug.cgi?id=13772
  28. "${FILESDIR}/${P}-hunspell140_fix.patch"
  29. "${FILESDIR}/${P}-hunspell150_fix.patch"
  30. )
  31. src_prepare() {
  32. default
  33. sed -i \
  34. -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
  35. tests/Makefile.am || die
  36. mv configure.in configure.ac || die
  37. AT_M4DIR=ac-helpers eautoreconf
  38. }
  39. src_configure() {
  40. econf \
  41. $(use_enable aspell) \
  42. $(use_enable hunspell myspell) \
  43. $(use_with hunspell system-myspell) \
  44. $(use_enable static-libs static) \
  45. $(use_enable zemberek) \
  46. --disable-ispell \
  47. --with-myspell-dir="${EPREFIX}"/usr/share/myspell/
  48. }
  49. src_install() {
  50. default
  51. prune_libtool_files --modules
  52. }