htmlc-2.40.0.ebuild 877 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
  5. MY_P="${P/0[.]/.}"
  6. DESCRIPTION="HTML template files expander"
  7. HOMEPAGE="http://htmlc.inria.fr/"
  8. SRC_URI="http://htmlc.inria.fr/${MY_P}.tgz"
  9. LICENSE="htmlc"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc x86"
  12. IUSE="+ocamlopt"
  13. # Files for the tests are missing...
  14. #RESTRICT="test"
  15. DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
  16. RDEPEND="${DEPEND}"
  17. S="${WORKDIR}/${MY_P}"
  18. src_configure() {
  19. ./configure \
  20. --install-root-dir "${ED}usr" \
  21. || die
  22. }
  23. src_compile() {
  24. if use ocamlopt ; then
  25. emake bin
  26. else
  27. emake byt
  28. fi
  29. }
  30. src_install() {
  31. if use ocamlopt ; then
  32. emake installbin
  33. else
  34. emake installbyt
  35. fi
  36. emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
  37. dodoc README Announce* CHANGES
  38. }