libabw-0.1.1.ebuild 993 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Library parsing abiword documents"
  6. HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
  7. SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE="doc static-libs"
  12. RDEPEND="
  13. dev-libs/librevenge
  14. dev-libs/libxml2
  15. sys-libs/zlib
  16. "
  17. DEPEND="${RDEPEND}
  18. >=dev-libs/boost-1.46
  19. sys-devel/libtool
  20. virtual/pkgconfig
  21. doc? ( app-doc/doxygen )
  22. "
  23. PATCHES=(
  24. # from git master
  25. "${FILESDIR}/${PN}-0.1.1-dereference-before-null-check.patch"
  26. "${FILESDIR}/${PN}-0.1.1-do-not-let-AbiDocument_parse-throw.patch"
  27. "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
  28. )
  29. src_prepare() {
  30. default
  31. eautoreconf
  32. }
  33. src_configure() {
  34. econf \
  35. --disable-werror \
  36. $(use_with doc docs) \
  37. $(use_enable static-libs static)
  38. }
  39. src_install() {
  40. default
  41. find "${D}" -name '*.la' -delete || die
  42. }