libpaper-1.1.24_p5.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools multilib-minimal
  5. MY_PV=${PV/_p/+nmu}
  6. DESCRIPTION="Library for handling paper characteristics"
  7. HOMEPAGE="http://packages.debian.org/unstable/source/libpaper"
  8. SRC_URI="mirror://debian/pool/main/libp/libpaper/${PN}_${MY_PV}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  12. IUSE=""
  13. RDEPEND="abi_x86_32? (
  14. !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
  15. !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
  16. )"
  17. DEPEND=""
  18. S="${WORKDIR}/${PN}-${MY_PV}"
  19. DOCS=( README ChangeLog debian/changelog )
  20. src_prepare() {
  21. sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
  22. eautoreconf
  23. default
  24. }
  25. multilib_src_configure() {
  26. ECONF_SOURCE="${S}" econf \
  27. --disable-static
  28. }
  29. multilib_src_install_all() {
  30. find "${ED}" -name '*.la' -exec rm -f {} +
  31. einstalldocs
  32. dodir /etc
  33. (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
  34. || die "papersize config failed"
  35. if ! has_version app-text/libpaper ; then
  36. echo
  37. elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
  38. echo
  39. fi
  40. }