libstaroffice-9999.ebuild 926 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
  5. [[ ${PV} == 9999 ]] && inherit git-r3 autotools
  6. DESCRIPTION="Import filter for old StarOffice documents"
  7. HOMEPAGE="https://github.com/fosnola/libstaroffice"
  8. [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
  9. LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
  10. SLOT="0"
  11. [[ ${PV} == 9999 ]] || \
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="debug doc tools +zlib"
  14. RDEPEND="
  15. dev-libs/librevenge
  16. zlib? ( sys-libs/zlib )
  17. "
  18. DEPEND="${RDEPEND}
  19. doc? ( app-doc/doxygen )
  20. "
  21. src_prepare() {
  22. default
  23. [[ ${PV} == 9999 ]] && eautoreconf
  24. }
  25. src_configure() {
  26. econf \
  27. --disable-werror \
  28. $(use_enable debug) \
  29. $(use_with doc docs) \
  30. $(use_enable tools) \
  31. $(use_enable zlib zip)
  32. }
  33. src_install() {
  34. default
  35. find "${D}" -name '*.la' -delete || die
  36. }