multitail-6.4.1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic toolchain-funcs
  5. DESCRIPTION="Tail with multiple windows"
  6. HOMEPAGE="http://www.vanheusden.com/multitail/"
  7. SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE="debug examples unicode"
  12. RDEPEND="
  13. sys-libs/ncurses:0=[unicode?]
  14. "
  15. DEPEND="
  16. ${RDEPEND}
  17. virtual/pkgconfig
  18. "
  19. RESTRICT="test" # bug #492270
  20. src_prepare() {
  21. epatch \
  22. "${FILESDIR}"/${PN}-6.4.1-gentoo.patch
  23. sed \
  24. -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
  25. -i Makefile || die
  26. sed \
  27. -e "s:/usr/bin/xclip:${EPREFIX}/usr/bin/xclip:g" \
  28. -i xclip.c ${PN}.conf || die
  29. tc-export CC PKG_CONFIG
  30. use debug && append-flags "-D_DEBUG"
  31. }
  32. src_compile() {
  33. emake UTF8_SUPPORT=$(usex unicode)
  34. }
  35. src_install () {
  36. dobin multitail
  37. insinto /etc
  38. doins multitail.conf
  39. DOCS=( readme.txt thanks.txt )
  40. HTML_DOCS=( manual.html )
  41. einstalldocs
  42. doman multitail.1
  43. if use examples; then
  44. docinto examples
  45. dodoc conversion-scripts/colors-example.{pl,sh} conversion-scripts/convert-{geoip,simple}.pl
  46. fi
  47. }
  48. pkg_postinst() {
  49. optfeature "send a buffer to the X clipboard" x11-misc/xclip
  50. }