paperwork-1.1-r1.ebuild 913 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{3_4,3_5} )
  5. inherit distutils-r1
  6. DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
  7. HOMEPAGE="https://github.com/jflesch/paperwork"
  8. SRC_URI="https://github.com/jflesch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
  14. dev-python/libpillowfight[${PYTHON_USEDEP}]
  15. dev-python/pillow[${PYTHON_USEDEP}]
  16. dev-python/pycairo[${PYTHON_USEDEP}]
  17. dev-python/pyenchant[${PYTHON_USEDEP}]
  18. dev-python/pygobject:3[${PYTHON_USEDEP}]
  19. dev-python/pyinsane:2[${PYTHON_USEDEP}]
  20. >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
  21. dev-python/simplebayes[${PYTHON_USEDEP}]
  22. dev-util/glade[introspection,python]
  23. x11-libs/gtk+:3[introspection]"
  24. DEPEND="${RDEPEND}"