reed-5.4.ebuild 904 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="This is a text pager (text file viewer), used to display etexts"
  6. # Homepage http://www.sacredchao.net/software/reed/index.shtml does not exist.
  7. HOMEPAGE="http://web.archive.org/web/20040217010815/www.sacredchao.net/software/reed/"
  8. SRC_URI="http://www.sacredchao.net/software/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 x86"
  12. DEPEND="sys-libs/ncurses"
  13. RDEPEND="${DEPEND}"
  14. DOCS=( AUTHORS BUGS NEWS README )
  15. src_prepare() {
  16. sed -e 's:-O2:$(CFLAGS) $(LDFLAGS):' \
  17. -e 's: wrap::' \
  18. -e 's:-s reed:reed:' \
  19. -e 's:-lcurses:$(shell ${PKG_CONFIG} --libs ncurses):g' \
  20. -i Makefile.in || die
  21. rm wrap.1 #Collision with talkfilters, bug #247396
  22. tc-export CC PKG_CONFIG
  23. }
  24. src_configure() {
  25. ./configures --prefix=/usr || die
  26. }