restview-2.4.0.ebuild 708 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} pypy )
  5. inherit distutils-r1
  6. DESCRIPTION="reStructuredText viewer"
  7. HOMEPAGE="https://mg.pov.lt/restview/ https://pypi.python.org/pypi/restview"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="test"
  13. RDEPEND="
  14. dev-python/setuptools[${PYTHON_USEDEP}]
  15. dev-python/docutils[${PYTHON_USEDEP}]
  16. dev-python/pygments[${PYTHON_USEDEP}]
  17. dev-python/readme[${PYTHON_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}
  20. test? ( dev-python/mock[${PYTHON_USEDEP}] )
  21. "
  22. DOCS=( README.rst CHANGES.rst )
  23. python_test() {
  24. esetup.py test
  25. }