robodoc-4.99.36.ebuild 817 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Automating Software Documentation"
  5. HOMEPAGE="http://www.xs4all.nl/~rfsber/Robo/robodoc.html"
  6. SRC_URI="http://www.xs4all.nl/~rfsber/Robo/DistSource/${P}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="examples"
  11. RDEPEND=">=dev-util/ctags-5.3.1"
  12. DEPEND="${RDEPEND}"
  13. src_configure() {
  14. econf \
  15. --docdir=/usr/share/doc/${PF} \
  16. --disable-dependency-tracking
  17. }
  18. src_install() {
  19. emake DESTDIR="${D}" install || die "emake install failed"
  20. insinto /usr/share/${PN}
  21. doins Contributions/* || die "doins failed"
  22. rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
  23. if use examples; then
  24. insinto /usr/share/${PN}
  25. doins -r Examples/PerlExample || die "doins failed"
  26. fi
  27. }