sablotron-1.0.3.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit base autotools
  5. MY_PN="Sablot"
  6. MY_P="${MY_PN}-${PV}"
  7. S=${WORKDIR}/${MY_P}
  8. DESCRIPTION="An XSLT Parser in C++"
  9. HOMEPAGE="http://www.gingerall.org/sablotron.html"
  10. SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
  11. # Sablotron can optionally be built under GPL, using MPL for now
  12. LICENSE="MPL-1.1"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
  15. IUSE="perl"
  16. RDEPEND=">=dev-libs/expat-1.95.6-r1"
  17. DEPEND="${RDEPEND}
  18. >=dev-perl/XML-Parser-2.3"
  19. PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )
  20. src_prepare() {
  21. base_src_prepare
  22. sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
  23. eautoreconf
  24. elibtoolize
  25. }
  26. src_configure() {
  27. econf \
  28. $(use_enable perl perlconnect) \
  29. --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
  30. }
  31. src_install() {
  32. emake DESTDIR="${D}" install || die "Install failed"
  33. dodoc README README_JS RELEASE src/TODO
  34. }