sigil-0.9.6.ebuild 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_4 python3_5 )
  5. inherit cmake-utils python-single-r1
  6. my_pn="Sigil"
  7. DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format"
  8. HOMEPAGE="http://sigil-ebook.com/"
  9. SRC_URI="https://github.com/Sigil-Ebook/${my_pn}/releases/download/${PV}/${my_pn}-${PV}-Code.zip"
  10. LICENSE="GPL-3+"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND="
  15. app-text/hunspell
  16. dev-libs/boost[threads]
  17. dev-libs/libpcre[pcre16]
  18. dev-libs/xerces-c[icu]
  19. dev-python/chardet[${PYTHON_USEDEP}]
  20. dev-python/cssselect[${PYTHON_USEDEP}]
  21. dev-python/cssutils[${PYTHON_USEDEP}]
  22. dev-python/html5lib[${PYTHON_USEDEP}]
  23. dev-python/lxml[${PYTHON_USEDEP}]
  24. dev-python/pillow[${PYTHON_USEDEP}]
  25. dev-python/regex[${PYTHON_USEDEP}]
  26. dev-python/six[${PYTHON_USEDEP}]
  27. >=dev-qt/qtconcurrent-5.4:5
  28. >=dev-qt/qtcore-5.4:5
  29. >=dev-qt/qtgui-5.4:5
  30. >=dev-qt/qtprintsupport-5.4:5
  31. >=dev-qt/qtwebkit-5.4:5
  32. >=dev-qt/qtwidgets-5.4:5
  33. >=dev-qt/qtxmlpatterns-5.4:5
  34. sys-libs/zlib[minizip]
  35. "
  36. DEPEND="${RDEPEND}
  37. >=sys-devel/gcc-4.8
  38. virtual/pkgconfig
  39. >=dev-qt/linguist-tools-5.4:5
  40. app-arch/unzip
  41. "
  42. S="${WORKDIR}"
  43. DOCS=( ChangeLog.txt README.md )
  44. src_prepare() {
  45. # sigil tries to copy non-needed qt libs for deb package, safe to ignore this completely
  46. eapply "${FILESDIR}/sigil-0.9.4-proper-gumbo-install.patch"
  47. eapply_user
  48. cmake-utils_src_prepare
  49. }
  50. src_configure() {
  51. local mycmakeargs=(
  52. -DUSE_SYSTEM_LIBS=1
  53. -DSYSTEM_LIBS_REQUIRED=1
  54. -DLIBDIR="$(get_libdir)"
  55. )
  56. cmake-utils_src_configure
  57. }
  58. pkg_postinst() {
  59. elog "From Sigil's release notes:"
  60. elog "When you fire up Sigil for the very first time:"
  61. elog "navigate to the new General Preferences and select the default"
  62. elog "epub version you plan to work with (epub 2 or epub3) so that new"
  63. elog "empty ebooks start with the correct code."
  64. elog "if you plan to work with epub3 epubs, you should change your"
  65. elog "PreserveEntities setting to use ONLY NUMERIC entities."
  66. elog ""
  67. elog "For example use & # 1 6 0 ; for non-breaking spaces and etc."
  68. elog ""
  69. elog "We strongly recommend enabling Mend On Open in your settings"
  70. elog "for best performance with Sigil."
  71. }