tokyodystopia-0.9.15.ebuild 851 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils
  5. DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
  6. HOMEPAGE="http://fallabs.com/tokyodystopia/"
  7. SRC_URI="${HOMEPAGE}${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="examples"
  12. DEPEND="dev-db/tokyocabinet"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}/fix_rpath.patch"
  16. epatch "${FILESDIR}/fix_ldconfig.patch"
  17. epatch "${FILESDIR}/remove_docinst.patch"
  18. }
  19. src_configure() {
  20. econf --libexecdir=/usr/libexec/${PN} || die
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" install || die "Install failed"
  24. dohtml doc/* || die
  25. if use examples; then
  26. insinto /usr/share/${PF}/example
  27. doins example/* || die "Install failed"
  28. fi
  29. }
  30. src_test() {
  31. emake -j1 check || die "Tests failed"
  32. }