tree-1.7.0.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs flag-o-matic bash-completion-r1
  5. DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
  6. HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
  7. SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND="!=sci-biology/meme-4.8.1"
  13. DEPEND=""
  14. src_prepare() {
  15. sed -i -e 's:LINUX:__linux__:' tree.c || die
  16. mv doc/tree.1.fr doc/tree.fr.1
  17. if use !elibc_glibc ; then
  18. # 433972, also previously done only for elibc_uclibc
  19. sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
  20. fi
  21. }
  22. src_compile() {
  23. append-lfs-flags
  24. emake \
  25. CC="$(tc-getCC)" \
  26. CFLAGS="${CFLAGS} ${CPPFLAGS}" \
  27. LDFLAGS="${LDFLAGS}"
  28. }
  29. src_install() {
  30. dobin tree
  31. doman doc/tree*.1
  32. dodoc CHANGES README*
  33. newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
  34. }