ttf2pk2-1.5_p20120701.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
  5. HOMEPAGE="http://tug.org/texlive/"
  6. SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  10. IUSE=""
  11. # Note about blockers: it is a freetype2 based replacement for ttf2pk and
  12. # ttf2tfm from freetype1, so block freetype1.
  13. # It installs some data that collides with
  14. # dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
  15. # meanwhile we can start dropping freetype1.
  16. RDEPEND=">=dev-libs/kpathsea-6.0.1_p20110627
  17. media-libs/freetype:2
  18. sys-libs/zlib
  19. !media-libs/freetype:1
  20. !=dev-texlive/texlive-langcjk-2011*[source]"
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig"
  23. S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
  24. src_configure() {
  25. econf --with-system-kpathsea \
  26. --with-system-freetype2 \
  27. --with-system-zlib
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install
  31. dodoc BUGS README TODO ChangeLog
  32. }