xindy-2.4-r1.ebuild 808 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="A Flexible Indexing System"
  6. HOMEPAGE="http://www.xindy.org/"
  7. SRC_URI="http://www.xindy.org/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
  11. IUSE="doc"
  12. RDEPEND="virtual/latex-base
  13. dev-texlive/texlive-fontsrecommended
  14. >=dev-lisp/clisp-2.44.1-r1
  15. dev-texlive/texlive-langcyrillic"
  16. DEPEND="${RDEPEND}
  17. dev-lang/perl
  18. sys-devel/flex"
  19. PATCHES=("${FILESDIR}"/${P}-configure.patch
  20. "${FILESDIR}"/${P}-locale.patch
  21. "${FILESDIR}"/${P}-nogrep.patch)
  22. DOCS=(AUTHORS ChangeLog.Gour NEWS README)
  23. src_prepare() {
  24. default
  25. eautoreconf
  26. }
  27. src_configure() {
  28. econf $(use_enable doc docs)
  29. }
  30. src_compile() {
  31. VARTEXFONTS="${T}/fonts" emake
  32. }