xournal-0.4.8.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG=no
  5. inherit gnome2
  6. DESCRIPTION="An application for notetaking, sketching, and keeping a journal using a stylus"
  7. HOMEPAGE="http://xournal.sourceforge.net/"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. IUSE="+pdf"
  11. if [[ "${PV}" != "9999" ]]; then
  12. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  13. KEYWORDS="amd64 x86"
  14. else
  15. inherit git-2 autotools
  16. SRC_URI=""
  17. KEYWORDS=""
  18. EGIT_REPO_URI="git://git.code.sf.net/p/xournal/code"
  19. EGIT_PROJECT="${PN}"
  20. EGIT_BOOTSTRAP="autogen.sh"
  21. fi
  22. COMMONDEPEND="
  23. app-text/poppler:=[cairo]
  24. dev-libs/atk
  25. dev-libs/glib
  26. gnome-base/libgnomecanvas
  27. media-libs/freetype
  28. media-libs/fontconfig
  29. sys-libs/zlib
  30. x11-libs/cairo
  31. x11-libs/gdk-pixbuf
  32. x11-libs/gtk+:2
  33. x11-libs/pango
  34. "
  35. RDEPEND="${COMMONDEPEND}
  36. pdf? ( app-text/poppler[utils] app-text/ghostscript-gpl )
  37. "
  38. DEPEND="${COMMONDEPEND}
  39. virtual/pkgconfig
  40. "
  41. src_install() {
  42. emake DESTDIR="${D}" install
  43. emake DESTDIR="${D}" desktop-install
  44. dodoc ChangeLog AUTHORS README
  45. dohtml -r html-doc/*
  46. }