12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=4
- inherit cmake-utils
- DESCRIPTION="C++ template library for linear algebra"
- HOMEPAGE="http://eigen.tuxfamily.org/"
- SRC_URI="https://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
- LICENSE="GPL-3"
- KEYWORDS="alpha amd64 ~arm ~hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
- SLOT="2"
- IUSE="debug doc examples"
- COMMON_DEPEND="
- examples? (
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
- )"
- DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )"
- RDEPEND="${COMMON_DEPEND}
- !dev-cpp/eigen:0"
- MAKEOPTS+=" -j1"
- # bugs 426236, 455460, 467288
- RESTRICT="test"
- src_unpack() {
- unpack ${A}
- mv ${PN}* ${P} || die
- }
- src_configure() {
- # benchmarks (BTL) brings up damn load of external deps including fortran
- # compiler
- # library hangs up complete compilation proccess, test later
- mycmakeargs=(
- -DEIGEN_BUILD_LIB=OFF
- -DEIGEN_BUILD_BTL=OFF
- -DEIGEN_BUILD_PKGCONFIG=ON
- $(cmake-utils_use examples EIGEN_BUILD_DEMOS)
- )
- cmake-utils_src_configure
- }
- src_compile() {
- cmake-utils_src_compile
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"
- emake doc
- fi
- }
- src_install() {
- cmake-utils_src_install
- if use doc; then
- cd "${CMAKE_BUILD_DIR}"/doc
- dohtml -r html/*
- fi
- if use examples; then
- cd "${CMAKE_BUILD_DIR}"/demos
- dobin mandelbrot/mandelbrot opengl/quaternion_demo
- fi
- }
- src_test() {
- mycmakeargs=(
- -DEIGEN_BUILD_TESTS=ON
- -DEIGEN_TEST_NO_FORTRAN=ON
- )
- cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
- }
|