threadpool-0.2.5-r1.ebuild 888 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
  5. HOMEPAGE="http://threadpool.sourceforge.net/"
  6. MY_PV=${PV//./_}
  7. MY_P=${PN}-${MY_PV}
  8. SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
  9. SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
  10. doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
  11. LICENSE="Boost-1.0"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="doc"
  15. DEPEND=""
  16. RDEPEND="dev-libs/boost"
  17. S="${WORKDIR}/${MY_P}-src/${PN}"
  18. DOCS=( README TODO CHANGE_LOG )
  19. PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
  20. src_compile() {
  21. # Do nothing
  22. # The makefile just builds the documentation again
  23. # Not even any install targets
  24. return
  25. }
  26. src_install() {
  27. doheader -r boost
  28. use doc && HTML_DOCS+=( "${WORKDIR}"/"${MY_P}"-doc/. )
  29. einstalldocs
  30. }