oracle-instantclient-jdbc-11.2.0.2.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils multilib
  4. MY_P_x86="${PN/oracle-/}-linux32-${PV}.0"
  5. MY_P_amd64="${PN/oracle-instantclient-/instantclient-}-linux-x86-64-${PV}.0"
  6. S="${WORKDIR}"
  7. DESCRIPTION="Oracle 11g client installation for Linux: JDBC supplement"
  8. HOMEPAGE="http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html"
  9. SRC_URI="x86? ( ${MY_P_x86}.zip )
  10. amd64? ( ${MY_P_amd64}.zip )"
  11. LICENSE="OTN"
  12. SLOT="0"
  13. KEYWORDS="~x86 ~amd64"
  14. RESTRICT="fetch"
  15. IUSE=""
  16. RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
  17. DEPEND="${RDEPEND}
  18. app-arch/unzip"
  19. pkg_setup() {
  20. MY_P=MY_P_${ARCH}
  21. export MY_P=${!MY_P}
  22. }
  23. pkg_nofetch() {
  24. eerror "Please go to:"
  25. eerror " ${HOMEPAGE}"
  26. eerror "and download the JDBC supplemental package. Put it in:"
  27. eerror " ${DISTDIR}"
  28. eerror "after downloading it."
  29. }
  30. src_unpack() {
  31. unzip "${DISTDIR}"/${MY_P}.zip
  32. }
  33. src_install() {
  34. dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
  35. cd "${S}"/instantclient_11_2
  36. insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
  37. doins libheteroxa11.so orai18n.jar
  38. }
  39. pkg_postinst() {
  40. elog "The JDBC supplement package for Oracle 11g has been installed."
  41. elog "You may wish to install the oracle-instantclient-sqlplus (for "
  42. elog "running the SQL*Plus application) package as well."
  43. }