tokumx-1.5.0-r2.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. CMAKE_BUILD_TYPE=Release
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit python-r1 pax-utils cmake-utils
  7. MY_P=${PN}-git-tag-${PV}
  8. DESCRIPTION="An open source, high-performance distribution of MongoDB"
  9. HOMEPAGE="http://www.tokutek.com/products/tokumx-for-mongodb/"
  10. SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
  11. LICENSE="AGPL-3 Apache-2.0"
  12. SLOT="0"
  13. KEYWORDS="~amd64"
  14. IUSE="pax_kernel"
  15. RDEPEND="
  16. dev-libs/jemalloc
  17. >=dev-libs/boost-1.50[threads(+)]
  18. >=dev-libs/libpcre-8.30[cxx]
  19. net-libs/libpcap"
  20. DEPEND="${RDEPEND}
  21. sys-libs/ncurses
  22. sys-libs/readline
  23. pax_kernel? ( sys-apps/paxctl sys-apps/elfix )"
  24. S="${WORKDIR}/mongo"
  25. BUILD_DIR="${WORKDIR}/mongo/build"
  26. QA_PRESTRIPPED="/usr/lib64/libHotBackup.so"
  27. src_prepare() {
  28. cd "${WORKDIR}"
  29. epatch "${FILESDIR}/${PV}-Werror.diff"
  30. epatch "${FILESDIR}/${PV}-boost-57.diff"
  31. epatch "${FILESDIR}/${PN}-disable-bundled-libs.patch"
  32. cd "${S}"
  33. cmake-utils_src_prepare
  34. }
  35. src_configure() {
  36. local mycmakeargs=(
  37. -D TOKU_DEBUG_PARANOID=OFF
  38. -D USE_VALGRIND=OFF
  39. -D USE_BDB=OFF
  40. -D BUILD_TESTING=OFF
  41. -D TOKUMX_DISTNAME=${PV}
  42. -D LIBJEMALLOC="jemalloc"
  43. -D TOKUMX_STRIP_BINARIES=0
  44. -D USE_SYSTEM_PCRE=1
  45. -D USE_SYSTEM_BOOST=1
  46. )
  47. cmake-utils_src_configure
  48. }
  49. src_install() {
  50. cmake-utils_src_install
  51. pax-mark -m "${D}"/usr/bin/mongo
  52. # Remove unnecessary files
  53. rm -r "${D}usr/buildscripts" "${D}usr/scripts" "${D}usr/src" "${D}usr/include/db.h" || die
  54. # Correctly install this python script
  55. python_foreach_impl python_doscript scripts/tokumxstat.py
  56. # Clean up documentation installed to /usr
  57. pushd "${D}usr/" || die
  58. rm GNU-AGPL-3.0 LICENSE.txt NEWS README README.md README-TOKUDB README-TOKUKV SConstruct THIRD-PARTY-NOTICES || die
  59. popd || die
  60. dodoc README.md distsrc/NEWS distsrc/README distsrc/THIRD-PARTY-NOTICES
  61. newdoc src/third_party/ft-index/README-TOKUDB README-TOKUKV
  62. }