pe-format-2.1.2.ebuild 754 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils fdo-mime systemd
  5. DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
  6. HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
  7. SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND="!<sys-apps/openrc-0.9.4"
  13. src_configure() {
  14. local myeconfargs=(
  15. "$(systemd_with_unitdir)"
  16. )
  17. autotools-utils_src_configure
  18. }
  19. src_install() {
  20. autotools-utils_src_install
  21. keepdir /var/lib
  22. }
  23. pkg_postinst() {
  24. ebegin "Calling pe-format2-setup to update handler setup"
  25. pe-format2-setup
  26. eend ${?}
  27. fdo-mime_desktop_database_update
  28. }