xdt-for-monodevelop-2.8.3.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit dotnet eutils
  5. DESCRIPTION="Microsoft's Xml Document Transformation library"
  6. HOMEPAGE="https://github.com/mrward/xdt"
  7. LICENSE="Apache-2.0"
  8. SLOT="0"
  9. SRC_URI="https://github.com/mrward/xdt/archive/Release-NuGet-${PV}-Mono.tar.gz -> xdt-for-monodevelop-${PV}.tar.gz"
  10. S=${WORKDIR}/xdt-Release-NuGet-${PV}-Mono
  11. KEYWORDS="~x86 ~amd64"
  12. IUSE=""
  13. DEPEND="|| ( dev-lang/mono )"
  14. RDEPEND="${DEPEND}"
  15. pkg_setup() {
  16. dotnet_pkg_setup
  17. }
  18. src_prepare() {
  19. epatch "${FILESDIR}/disable-testproject-build-in-sln.patch"
  20. cp "${FILESDIR}/rsa-4096.snk" "${S}/XmlTransform" || die
  21. epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
  22. sed -i -e "s/1.0.0/${PV}/g" "${S}/XmlTransform/Properties/AssemblyInfo.cs" || die
  23. }
  24. src_configure() {
  25. export EnableNuGetPackageRestore="true"
  26. }
  27. src_compile() {
  28. exbuild Microsoft.Web.XmlTransform.sln
  29. }
  30. src_install() {
  31. elog "Installing Microsoft.Web.XmlTransform.dll to GAC"
  32. egacinstall XmlTransform/bin/Release/Microsoft.Web.XmlTransform.dll
  33. }