esip-1.0.10.ebuild 707 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit rebar
  5. DESCRIPTION="ProcessOne SIP server component"
  6. HOMEPAGE="https://github.com/processone/esip"
  7. SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
  8. -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
  12. DEPEND=">=dev-erlang/fast_tls-1.0.9
  13. >=dev-erlang/stun-1.0.9
  14. >=dev-erlang/p1_utils-1.0.6
  15. >=dev-lang/erlang-17.1"
  16. RDEPEND="${DEPEND}"
  17. DOCS=( CHANGELOG.md README.md )
  18. src_prepare() {
  19. rebar_src_prepare
  20. rebar_fix_include_path stun
  21. # ebin contains lonely .gitignore file asking for removal.
  22. rm -r "${S}/ebin" || die
  23. }