fast_xml-1.1.3.ebuild 595 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit rebar
  5. DESCRIPTION="Fast Expat based Erlang XML parsing library"
  6. HOMEPAGE="https://github.com/processone/fast_xml"
  7. SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
  8. -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
  12. IUSE="test"
  13. RDEPEND=">=dev-erlang/p1_utils-1.0.0
  14. >=dev-lang/erlang-17.1
  15. <dev-lang/erlang-19
  16. dev-libs/expat"
  17. DEPEND="${RDEPEND}
  18. test? ( >=dev-lang/elixir-1.1 )"
  19. DOCS=( CHANGELOG.md README.md )