xmpp-1.1.9.ebuild 630 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit rebar
  5. DESCRIPTION="XMPP parsing and serialization library on top of Fast XML"
  6. HOMEPAGE="https://github.com/processone/xmpp"
  7. SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
  8. -> ${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
  12. IUSE="test"
  13. RDEPEND=">=dev-erlang/fast_xml-1.1.22
  14. >=dev-erlang/stringprep-1.0.8
  15. >=dev-lang/erlang-17.1"
  16. DEPEND="${RDEPEND}"
  17. DOCS=( CHANGELOG.md )
  18. src_prepare() {
  19. rebar_src_prepare
  20. rebar_fix_include_path fast_xml
  21. }