ant-nodeps-1.9.2.ebuild 932 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. ANT_TASK_DEPNAME=""
  5. ANT_TASK_DISABLE_VM_DEPS="true"
  6. inherit ant-tasks
  7. DESCRIPTION="Formerly Ant's optional tasks w/o external deps, now compat empty jar"
  8. KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  9. # Dependency needed for jar.
  10. DEPEND=">=virtual/jdk-1.4"
  11. src_compile() {
  12. # The classes were moved to ant-core in 1.8.2, this is just for compatibility.
  13. mkdir -p build/lib/empty && cd build/lib/empty || die
  14. jar -cf ../${PN}.jar . || die
  15. }
  16. pkg_postinst() {
  17. elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
  18. elog "This package thus installs an empty jar for compatibility"
  19. elog "and will be removed once reverse dependencies are transitioned."
  20. }