commons-graph-0.1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc source test"
  5. inherit java-pkg-2 java-ant-2
  6. DESCRIPTION="A toolkit for managing graphs and graph based data structures"
  7. HOMEPAGE="https://commons.apache.org/sandbox/commons-graph/"
  8. SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. DEPEND=">=virtual/jdk-1.6
  14. test? (
  15. dev-java/ant-junit:0
  16. )"
  17. RDEPEND=">=virtual/jre-1.6
  18. ${CDEPEND}"
  19. JAVA_ANT_REWRITE_CLASSPATH="yes"
  20. EANT_TEST_TARGET="test"
  21. # Dubious tests.
  22. JAVA_RM_FILES=(
  23. src/test/java/org/apache/commons/graph/coloring/GraphColoringTestCase.java
  24. src/test/java/org/apache/commons/graph/spanning/KruskalTestCase.java
  25. src/test/java/org/apache/commons/graph/scc/TarjanTestCase.java
  26. )
  27. java_prepare() {
  28. cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
  29. }
  30. src_test() {
  31. java-pkg-2_src_test
  32. }
  33. src_install() {
  34. java-pkg_newjar target/${P}.jar
  35. use doc && java-pkg_dojavadoc target/site/apidocs
  36. use source && java-pkg_dosrc src/main/java
  37. }