commons-vfs-1.0-r1.ebuild 936 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="A single Java API for accessing various different file systems"
  7. HOMEPAGE="https://commons.apache.org/vfs/"
  8. SRC_URI="https://archive.apache.org/dist/${PN/-//}/source/${P}-src.tar.gz" # Not on Apache mirrors.
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  12. RESTRICT="test" # Some failures, can't figure them out.
  13. CP_DEPEND="
  14. dev-java/ant-core:0
  15. dev-java/commons-collections:0
  16. dev-java/commons-httpclient:3
  17. dev-java/commons-logging:0
  18. dev-java/commons-net:0
  19. dev-java/jsch:0
  20. "
  21. RDEPEND=">=virtual/jre-1.7
  22. ${CP_DEPEND}"
  23. DEPEND=">=virtual/jdk-1.7
  24. ${CP_DEPEND}"
  25. S="${WORKDIR}/${P}-src"
  26. JAVA_SRC_DIR="core/src/main"
  27. src_install() {
  28. java-pkg-simple_src_install
  29. dodoc {NOTICE,RELEASE_NOTES}.txt
  30. }