geoip-java-1.3.0.ebuild 907 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="source doc examples"
  5. inherit java-pkg-2 java-pkg-simple
  6. MY_PN="geoip-api-java"
  7. DESCRIPTION="Java library for lookup countries by IP addresses"
  8. HOMEPAGE="https://github.com/maxmind"
  9. SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.zip -> ${P}.zip"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE=""
  14. RDEPEND=">=virtual/jre-1.6"
  15. DEPEND=">=virtual/jdk-1.6"
  16. S="${WORKDIR}/${MY_PN}-${PV}"
  17. JAVA_SRC_DIR="src"
  18. java_prepare() {
  19. rm -rv src/test || die
  20. }
  21. src_install() {
  22. java-pkg-simple_src_install
  23. dodoc README.md Changes.md
  24. use examples && java-pkg_doexamples examples/*
  25. }
  26. pkg_postinst() {
  27. einfo "Country and City data files can be downloaded here:"
  28. einfo " http://www.maxmind.com/app/geolitecountry"
  29. einfo " http://www.maxmind.com/app/geolitecity"
  30. }