gnu-classpath-inetlib-1.1-r3.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit java-pkg-2 java-ant-2
  4. MY_PN="inetlib"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="Network extensions library for GNU classpath and classpathx"
  7. HOMEPAGE="https://www.gnu.org/software/classpath/"
  8. SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
  9. LICENSE="GPL-2-with-linking-exception"
  10. SLOT="1.1"
  11. KEYWORDS="amd64 x86"
  12. IUSE="doc"
  13. RDEPEND=">=virtual/jre-1.3
  14. >=dev-java/gnu-crypto-2.0.1"
  15. DEPEND=">=virtual/jdk-1.3
  16. ${RDEPEND}"
  17. S="${WORKDIR}/${MY_PN}"
  18. src_unpack() {
  19. unpack ${A}
  20. cd "${S}"
  21. epatch "${FILESDIR}/${P}-jdk15.patch"
  22. mkdir ext && cd ext
  23. java-pkg_jar-from gnu-crypto
  24. # fake jar to shut build system up, jsse is part of JDK's classpath already
  25. ln -s javax-security.jar jsse.jar
  26. }
  27. src_compile() {
  28. econf \
  29. --enable-smtp \
  30. --enable-imap \
  31. --enable-pop3 \
  32. --enable-nntp \
  33. --enable-ftp \
  34. --enable-gopher \
  35. --with-jsse-jar="${S}"/ext \
  36. --with-javax-security-jar="${S}"/ext \
  37. || die
  38. # https://bugs.gentoo.org/show_bug.cgi?id=179897
  39. emake JAVACFLAGS="${JAVACFLAGS}" -j1 || die
  40. if use doc ; then
  41. emake -j1 javadoc || die
  42. fi
  43. }
  44. src_install() {
  45. einstall || die
  46. rm -rf "${D}"/usr/share/java
  47. java-pkg_dojar inetlib.jar
  48. use doc && java-pkg_dojavadoc docs
  49. dodoc AUTHORS NEWS README || die
  50. }