jcommander-1.48.ebuild 542 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="Command line parsing framework for Java"
  7. HOMEPAGE="https://github.com/cbeust/jcommander"
  8. SRC_URI="https://github.com/cbeust/${PN}/archive/${P}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. DEPEND=">=virtual/jdk-1.6"
  13. RDEPEND=">=virtual/jre-1.6"
  14. S="${WORKDIR}/${PN}-${P}"
  15. RESTRICT="test"
  16. java_prepare() {
  17. rm -rf src/test || die
  18. }