jikes-1.22-r13.ebuild 872 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit flag-o-matic eutils
  4. DESCRIPTION="IBM's open source, high performance Java compiler"
  5. HOMEPAGE="http://jikes.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  7. LICENSE="IBM"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm ppc64 x86 ~x86-fbsd"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND=">=dev-java/java-config-2.0.0"
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/deprecated.patch
  17. }
  18. src_compile() {
  19. filter-flags "-fno-rtti"
  20. econf || die "configure problem"
  21. emake || die "compile problem"
  22. }
  23. src_install () {
  24. make DESTDIR="${D}" install || die "install problem"
  25. dodoc ChangeLog AUTHORS README TODO NEWS
  26. mv "${D}"/usr/bin/jikes{,-bin}
  27. dobin "${FILESDIR}"/jikes
  28. insinto /usr/share/java-config-2/compiler
  29. newins "${FILESDIR}"/compiler-settings jikes
  30. }