jnlp-api-6.0.18.ebuild 605 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. JAVA_PKG_IUSE="source"
  5. inherit eutils java-pkg-2 java-pkg-simple
  6. DESCRIPTION="JNLP API classes, repackaged from the icedtea-web fork of netx"
  7. HOMEPAGE="http://jcp.org/en/jsr/detail?id=56"
  8. SRC_URI="https://dev.gentoo.org/~caster/distfiles/${P}.tar.bz2"
  9. LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="source"
  13. DEPEND=">=virtual/jdk-1.6"
  14. RDEPEND=">=virtual/jre-1.6"
  15. src_install() {
  16. java-pkg_dojar ${PN}.jar
  17. use source && java-pkg_dosrc javax
  18. }