jopt-simple-4.9.ebuild 656 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="A Java library for parsing command line options"
  7. HOMEPAGE="https://pholser.github.com/jopt-simple/"
  8. SRC_URI="https://github.com/pholser/${PN}/tarball/${P} -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc64 ~x86"
  12. IUSE=""
  13. RDEPEND=">=virtual/jre-1.6"
  14. DEPEND=">=virtual/jdk-1.6"
  15. S="${WORKDIR}/pholser-${PN}-94ad77a"
  16. JAVA_SRC_DIR="src/main/java"
  17. java_prepare() {
  18. rm -v pom.xml || die
  19. }
  20. src_install() {
  21. java-pkg-simple_src_install
  22. dodoc README.md
  23. }