jump-0.5-r1.ebuild 673 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc examples source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="Java-based extensible high-precision math library"
  7. HOMEPAGE="http://jump-math.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}-math/${P}.tar.gz"
  9. KEYWORDS="amd64 x86"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. RDEPEND="
  13. >=virtual/jre-1.6"
  14. DEPEND="
  15. >=virtual/jdk-1.6
  16. source? ( app-arch/zip )"
  17. S="${WORKDIR}/${P}"
  18. JAVA_SRC_DIR="src/main"
  19. java_prepare() {
  20. rm -rv src/tests || die
  21. }
  22. src_install() {
  23. java-pkg-simple_src_install
  24. use examples && java-pkg_doexamples src/examples
  25. }