123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="4"
- inherit eutils java-pkg-2 java-ant-2
- DESCRIPTION="Netbeans D-Light Cluster"
- HOMEPAGE="http://netbeans.org/"
- SLOT="8.1"
- SOURCE_URL="http://download.netbeans.org/netbeans/8.1/final/zip/netbeans-8.1-201510222201-src.zip"
- SRC_URI="${SOURCE_URL}
- http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.1-build.xml.patch.bz2
- http://hg.netbeans.org/binaries/51AC4960C19CF4C2CCA636765BFBC09A5029BFC5-fs_server-1.0.zip"
- LICENSE="|| ( CDDL GPL-2-with-classpath-exception )"
- KEYWORDS="~amd64 ~x86"
- IUSE=""
- S="${WORKDIR}"
- CDEPEND="~dev-java/netbeans-ide-${PV}
- ~dev-java/netbeans-platform-${PV}"
- DEPEND=">=virtual/jdk-1.7
- app-arch/unzip
- ${CDEPEND}
- dev-java/javahelp:0"
- RDEPEND=">=virtual/jdk-1.7
- ${CDEPEND}"
- INSTALL_DIR="/usr/share/${PN}-${SLOT}"
- EANT_BUILD_XML="nbbuild/build.xml"
- EANT_BUILD_TARGET="rebuild-cluster"
- EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.dlight -Dext.binaries.downloaded=true -Dpermit.jdk8.builds=true"
- EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
- JAVA_PKG_BSFIX="off"
- src_unpack() {
- unpack $(basename ${SOURCE_URL})
- einfo "Deleting bundled jars..."
- find -name "*.jar" -type f -delete
- unpack netbeans-8.1-build.xml.patch.bz2
- pushd "${S}" >/dev/null || die
- ln -s "${DISTDIR}"/51AC4960C19CF4C2CCA636765BFBC09A5029BFC5-fs_server-1.0.zip dlight.remote.impl/external/fs_server-1.0.zip || die
- popd >/dev/null || die
- }
- src_prepare() {
- einfo "Deleting bundled class files..."
- find -name "*.class" -type f | xargs rm -vf
- epatch netbeans-8.1-build.xml.patch
- # Support for custom patches
- if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
- local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
- if [ -n "${files}" ] ; then
- einfo "Applying custom patches:"
- for file in ${files} ; do
- epatch "${file}"
- done
- fi
- fi
- einfo "Symlinking external libraries..."
- java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
- einfo "Linking in other clusters..."
- mkdir "${S}"/nbbuild/netbeans || die
- pushd "${S}"/nbbuild/netbeans >/dev/null || die
- ln -s /usr/share/netbeans-ide-${SLOT} ide || die
- cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.ide.built
- ln -s /usr/share/netbeans-platform-${SLOT} platform || die
- cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.platform.built
- popd >/dev/null || die
- java-pkg-2_src_prepare
- }
- src_install() {
- pushd nbbuild/netbeans/dlight >/dev/null || die
- insinto ${INSTALL_DIR}
- grep -E "/dlight$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
- doins -r *
- popd >/dev/null || die
- dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/dlight
- }
|