netbeans-dlight-8.1.ebuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils java-pkg-2 java-ant-2
  5. DESCRIPTION="Netbeans D-Light Cluster"
  6. HOMEPAGE="http://netbeans.org/"
  7. SLOT="8.1"
  8. SOURCE_URL="http://download.netbeans.org/netbeans/8.1/final/zip/netbeans-8.1-201510222201-src.zip"
  9. SRC_URI="${SOURCE_URL}
  10. http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.1-build.xml.patch.bz2
  11. http://hg.netbeans.org/binaries/51AC4960C19CF4C2CCA636765BFBC09A5029BFC5-fs_server-1.0.zip"
  12. LICENSE="|| ( CDDL GPL-2-with-classpath-exception )"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. S="${WORKDIR}"
  16. CDEPEND="~dev-java/netbeans-ide-${PV}
  17. ~dev-java/netbeans-platform-${PV}"
  18. DEPEND=">=virtual/jdk-1.7
  19. app-arch/unzip
  20. ${CDEPEND}
  21. dev-java/javahelp:0"
  22. RDEPEND=">=virtual/jdk-1.7
  23. ${CDEPEND}"
  24. INSTALL_DIR="/usr/share/${PN}-${SLOT}"
  25. EANT_BUILD_XML="nbbuild/build.xml"
  26. EANT_BUILD_TARGET="rebuild-cluster"
  27. EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.dlight -Dext.binaries.downloaded=true -Dpermit.jdk8.builds=true"
  28. EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
  29. JAVA_PKG_BSFIX="off"
  30. src_unpack() {
  31. unpack $(basename ${SOURCE_URL})
  32. einfo "Deleting bundled jars..."
  33. find -name "*.jar" -type f -delete
  34. unpack netbeans-8.1-build.xml.patch.bz2
  35. pushd "${S}" >/dev/null || die
  36. ln -s "${DISTDIR}"/51AC4960C19CF4C2CCA636765BFBC09A5029BFC5-fs_server-1.0.zip dlight.remote.impl/external/fs_server-1.0.zip || die
  37. popd >/dev/null || die
  38. }
  39. src_prepare() {
  40. einfo "Deleting bundled class files..."
  41. find -name "*.class" -type f | xargs rm -vf
  42. epatch netbeans-8.1-build.xml.patch
  43. # Support for custom patches
  44. if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
  45. local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
  46. if [ -n "${files}" ] ; then
  47. einfo "Applying custom patches:"
  48. for file in ${files} ; do
  49. epatch "${file}"
  50. done
  51. fi
  52. fi
  53. einfo "Symlinking external libraries..."
  54. java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
  55. einfo "Linking in other clusters..."
  56. mkdir "${S}"/nbbuild/netbeans || die
  57. pushd "${S}"/nbbuild/netbeans >/dev/null || die
  58. ln -s /usr/share/netbeans-ide-${SLOT} ide || die
  59. cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  60. touch nb.cluster.ide.built
  61. ln -s /usr/share/netbeans-platform-${SLOT} platform || die
  62. cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  63. touch nb.cluster.platform.built
  64. popd >/dev/null || die
  65. java-pkg-2_src_prepare
  66. }
  67. src_install() {
  68. pushd nbbuild/netbeans/dlight >/dev/null || die
  69. insinto ${INSTALL_DIR}
  70. grep -E "/dlight$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
  71. doins -r *
  72. popd >/dev/null || die
  73. dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/dlight
  74. }