netbeans-javadoc-8.1.ebuild 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils java-pkg-2 java-ant-2
  5. DESCRIPTION="Netbeans JavaDocs"
  6. HOMEPAGE="http://netbeans.org/"
  7. SLOT="8.1"
  8. SOURCE_URL="http://download.netbeans.org/netbeans/8.1/final/zip/netbeans-8.1-201510222201-src.zip"
  9. SRC_URI="${SOURCE_URL}
  10. http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.1-build.xml.patch.bz2
  11. http://hg.netbeans.org/binaries/22CB933E3A1450B092C45785C187837E97523F5C-ant-libs-1.9.4.zip"
  12. LICENSE="|| ( CDDL GPL-2-with-classpath-exception )"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. S="${WORKDIR}"
  16. # oracle-jdk-bin is needed because of javafx which is not currently packaged separately
  17. DEPEND="dev-java/oracle-jdk-bin:1.8[javafx]
  18. app-arch/unzip
  19. dev-java/javahelp:0
  20. dev-java/junit:4
  21. ~dev-java/netbeans-apisupport-${PV}
  22. ~dev-java/netbeans-cnd-${PV}
  23. ~dev-java/netbeans-dlight-${PV}
  24. ~dev-java/netbeans-enterprise-${PV}
  25. ~dev-java/netbeans-ergonomics-${PV}
  26. ~dev-java/netbeans-extide-${PV}
  27. ~dev-java/netbeans-groovy-${PV}
  28. ~dev-java/netbeans-harness-${PV}
  29. ~dev-java/netbeans-ide-${PV}
  30. ~dev-java/netbeans-java-${PV}
  31. ~dev-java/netbeans-javacard-${PV}
  32. ~dev-java/netbeans-mobility-${PV}
  33. ~dev-java/netbeans-nb-${PV}
  34. ~dev-java/netbeans-php-${PV}
  35. ~dev-java/netbeans-platform-${PV}
  36. ~dev-java/netbeans-profiler-${PV}
  37. ~dev-java/netbeans-websvccommon-${PV}"
  38. RDEPEND=""
  39. JAVA_PKG_BSFIX="off"
  40. JAVA_PKG_WANT_BUILD_VM="oracle-jdk-bin-1.8"
  41. JAVA_PKG_WANT_SOURCE="1.7"
  42. JAVA_PKG_WANT_TARGET="1.7"
  43. src_unpack() {
  44. unpack $(basename ${SOURCE_URL})
  45. einfo "Deleting bundled jars..."
  46. find -name "*.jar" -type f -delete
  47. unpack netbeans-8.1-build.xml.patch.bz2
  48. pushd "${S}" >/dev/null || die
  49. ln -s "${DISTDIR}"/22CB933E3A1450B092C45785C187837E97523F5C-ant-libs-1.9.4.zip o.apache.tools.ant.module/external/ant-libs-1.9.4.zip || die
  50. popd >/dev/null || die
  51. }
  52. src_prepare() {
  53. einfo "Deleting bundled class files..."
  54. find -name "*.class" -type f | xargs rm -vf
  55. epatch netbeans-8.1-build.xml.patch
  56. # Support for custom patches
  57. if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
  58. local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
  59. if [ -n "${files}" ] ; then
  60. einfo "Applying custom patches:"
  61. for file in ${files} ; do
  62. epatch "${file}"
  63. done
  64. fi
  65. fi
  66. einfo "Symlinking external libraries..."
  67. java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
  68. java-pkg_jar-from --build-only --into libs.junit4/external junit-4 junit.jar junit-4.12.jar
  69. einfo "Linking in other clusters..."
  70. mkdir "${S}"/nbbuild/netbeans || die
  71. pushd "${S}"/nbbuild/netbeans >/dev/null || die
  72. ln -s /usr/share/netbeans-apisupport-${SLOT} apisupport || die
  73. cat /usr/share/netbeans-apisupport-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  74. touch nb.cluster.apisupport.built
  75. ln -s /usr/share/netbeans-cnd-${SLOT} cnd || die
  76. cat /usr/share/netbeans-cnd-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  77. touch nb.cluster.cnd.built
  78. ln -s /usr/share/netbeans-dlight-${SLOT} dlight || die
  79. cat /usr/share/netbeans-dlight-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  80. touch nb.cluster.dlight.built
  81. ln -s /usr/share/netbeans-enterprise-${SLOT} enterprise || die
  82. cat /usr/share/netbeans-enterprise-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  83. touch nb.cluster.enterprise.built
  84. ln -s /usr/share/netbeans-ergonomics-${SLOT} ergonomics || die
  85. cat /usr/share/netbeans-ergonomics-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  86. touch nb.cluster.ergonomics.built
  87. ln -s /usr/share/netbeans-extide-${SLOT} extide || die
  88. cat /usr/share/netbeans-extide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  89. touch nb.cluster.extide.built
  90. ln -s /usr/share/netbeans-groovy-${SLOT} groovy || die
  91. cat /usr/share/netbeans-groovy-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  92. touch nb.cluster.groovy.built
  93. ln -s /usr/share/netbeans-harness-${SLOT} harness || die
  94. cat /usr/share/netbeans-harness-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  95. touch nb.cluster.harness.built
  96. ln -s /usr/share/netbeans-ide-${SLOT} ide || die
  97. cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  98. touch nb.cluster.ide.built
  99. ln -s /usr/share/netbeans-java-${SLOT} java || die
  100. cat /usr/share/netbeans-java-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  101. touch nb.cluster.java.built
  102. ln -s /usr/share/netbeans-javacard-${SLOT} javacard || die
  103. cat /usr/share/netbeans-javacard-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  104. touch nb.cluster.javacard.built
  105. ln -s /usr/share/netbeans-mobility-${SLOT} mobility || die
  106. cat /usr/share/netbeans-mobility-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  107. touch nb.cluster.mobility.built
  108. ln -s /usr/share/netbeans-nb-${SLOT}/nb nb || die
  109. cat /usr/share/netbeans-nb-${SLOT}/nb/moduleCluster.properties >> moduleCluster.properties || die
  110. touch nb.cluster.nb.built
  111. ln -s /usr/share/netbeans-php-${SLOT} php || die
  112. cat /usr/share/netbeans-php-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  113. touch nb.cluster.php.built
  114. ln -s /usr/share/netbeans-platform-${SLOT} platform || die
  115. cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  116. touch nb.cluster.platform.built
  117. ln -s /usr/share/netbeans-profiler-${SLOT} profiler || die
  118. cat /usr/share/netbeans-profiler-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  119. touch nb.cluster.profiler.built
  120. ln -s /usr/share/netbeans-websvccommon-${SLOT} websvccommon || die
  121. cat /usr/share/netbeans-websvccommon-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  122. touch nb.cluster.websvccommon.built
  123. java-pkg-2_src_prepare
  124. }
  125. src_compile() {
  126. eant -Dpermit.jdk8.builds=true -f nbbuild/build.xml bootstrap || die
  127. ANT_OPTS="-Xmx1536m" eant -Dpermit.jdk8.builds=true -f nbbuild/javadoctools/build.xml build-javadoc
  128. }
  129. src_install() {
  130. rm nbbuild/build/javadoc/*.zip
  131. java-pkg_dojavadoc nbbuild/build/javadoc
  132. }