netbeans-javadoc-8.2.ebuild 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit eutils java-pkg-2 java-ant-2
  5. DESCRIPTION="Netbeans JavaDocs"
  6. HOMEPAGE="http://netbeans.org/"
  7. SLOT="8.2"
  8. SOURCE_URL="http://download.netbeans.org/netbeans/8.2/final/zip/netbeans-8.2-201609300101-src.zip"
  9. SRC_URI="${SOURCE_URL}
  10. http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.2-build.xml.patch.bz2
  11. http://hg.netbeans.org/binaries/BEA15848D713D491C6EBA1307E0564A5BC3965E7-ant-libs-1.9.7.zip"
  12. LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
  13. KEYWORDS="amd64 ~x86"
  14. IUSE=""
  15. S="${WORKDIR}"
  16. # oracle-jdk-bin is needed because of javafx which is not currently packaged separately
  17. DEPEND="dev-java/oracle-jdk-bin:1.8[javafx]
  18. app-arch/unzip
  19. dev-java/javahelp:0
  20. dev-java/junit:4
  21. ~dev-java/netbeans-apisupport-${PV}
  22. ~dev-java/netbeans-cnd-${PV}
  23. ~dev-java/netbeans-dlight-${PV}
  24. ~dev-java/netbeans-enterprise-${PV}
  25. ~dev-java/netbeans-ergonomics-${PV}
  26. ~dev-java/netbeans-extide-${PV}
  27. ~dev-java/netbeans-groovy-${PV}
  28. ~dev-java/netbeans-harness-${PV}
  29. ~dev-java/netbeans-ide-${PV}
  30. ~dev-java/netbeans-java-${PV}
  31. ~dev-java/netbeans-javacard-${PV}
  32. ~dev-java/netbeans-mobility-${PV}
  33. ~dev-java/netbeans-nb-${PV}
  34. ~dev-java/netbeans-php-${PV}
  35. ~dev-java/netbeans-platform-${PV}
  36. ~dev-java/netbeans-profiler-${PV}
  37. ~dev-java/netbeans-websvccommon-${PV}"
  38. RDEPEND=""
  39. JAVA_PKG_BSFIX="off"
  40. JAVA_PKG_WANT_BUILD_VM="oracle-jdk-bin-1.8"
  41. JAVA_PKG_WANT_SOURCE="1.7"
  42. JAVA_PKG_WANT_TARGET="1.7"
  43. src_unpack() {
  44. unpack $(basename ${SOURCE_URL})
  45. einfo "Deleting bundled jars..."
  46. find -name "*.jar" -type f -delete
  47. unpack netbeans-8.2-build.xml.patch.bz2
  48. pushd "${S}" >/dev/null || die
  49. ln -s "${DISTDIR}"/BEA15848D713D491C6EBA1307E0564A5BC3965E7-ant-libs-1.9.7.zip o.apache.tools.ant.module/external/ant-libs-1.9.7.zip || die
  50. popd >/dev/null || die
  51. }
  52. src_prepare() {
  53. einfo "Deleting bundled class files..."
  54. find -name "*.class" -type f | xargs rm -vf
  55. epatch netbeans-8.2-build.xml.patch
  56. einfo "Symlinking external libraries..."
  57. java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
  58. java-pkg_jar-from --build-only --into libs.junit4/external junit-4 junit.jar junit-4.12.jar
  59. einfo "Linking in other clusters..."
  60. mkdir "${S}"/nbbuild/netbeans || die
  61. pushd "${S}"/nbbuild/netbeans >/dev/null || die
  62. ln -s /usr/share/netbeans-apisupport-${SLOT} apisupport || die
  63. cat /usr/share/netbeans-apisupport-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  64. touch nb.cluster.apisupport.built
  65. ln -s /usr/share/netbeans-cnd-${SLOT} cnd || die
  66. cat /usr/share/netbeans-cnd-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  67. touch nb.cluster.cnd.built
  68. ln -s /usr/share/netbeans-dlight-${SLOT} dlight || die
  69. cat /usr/share/netbeans-dlight-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  70. touch nb.cluster.dlight.built
  71. ln -s /usr/share/netbeans-enterprise-${SLOT} enterprise || die
  72. cat /usr/share/netbeans-enterprise-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  73. touch nb.cluster.enterprise.built
  74. ln -s /usr/share/netbeans-ergonomics-${SLOT} ergonomics || die
  75. cat /usr/share/netbeans-ergonomics-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  76. touch nb.cluster.ergonomics.built
  77. ln -s /usr/share/netbeans-extide-${SLOT} extide || die
  78. cat /usr/share/netbeans-extide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  79. touch nb.cluster.extide.built
  80. ln -s /usr/share/netbeans-groovy-${SLOT} groovy || die
  81. cat /usr/share/netbeans-groovy-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  82. touch nb.cluster.groovy.built
  83. ln -s /usr/share/netbeans-harness-${SLOT} harness || die
  84. cat /usr/share/netbeans-harness-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  85. touch nb.cluster.harness.built
  86. ln -s /usr/share/netbeans-ide-${SLOT} ide || die
  87. cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  88. touch nb.cluster.ide.built
  89. ln -s /usr/share/netbeans-java-${SLOT} java || die
  90. cat /usr/share/netbeans-java-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  91. touch nb.cluster.java.built
  92. ln -s /usr/share/netbeans-javacard-${SLOT} javacard || die
  93. cat /usr/share/netbeans-javacard-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  94. touch nb.cluster.javacard.built
  95. ln -s /usr/share/netbeans-mobility-${SLOT} mobility || die
  96. cat /usr/share/netbeans-mobility-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  97. touch nb.cluster.mobility.built
  98. ln -s /usr/share/netbeans-nb-${SLOT}/nb nb || die
  99. cat /usr/share/netbeans-nb-${SLOT}/nb/moduleCluster.properties >> moduleCluster.properties || die
  100. touch nb.cluster.nb.built
  101. ln -s /usr/share/netbeans-php-${SLOT} php || die
  102. cat /usr/share/netbeans-php-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  103. touch nb.cluster.php.built
  104. ln -s /usr/share/netbeans-platform-${SLOT} platform || die
  105. cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  106. touch nb.cluster.platform.built
  107. ln -s /usr/share/netbeans-profiler-${SLOT} profiler || die
  108. cat /usr/share/netbeans-profiler-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  109. touch nb.cluster.profiler.built
  110. ln -s /usr/share/netbeans-websvccommon-${SLOT} websvccommon || die
  111. cat /usr/share/netbeans-websvccommon-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
  112. touch nb.cluster.websvccommon.built
  113. java-pkg-2_src_prepare
  114. default
  115. }
  116. src_compile() {
  117. eant -Dpermit.jdk8.builds=true -f nbbuild/build.xml bootstrap || die
  118. ANT_OPTS="-Xmx1536m" eant -Dpermit.jdk8.builds=true -f nbbuild/javadoctools/build.xml build-javadoc
  119. }
  120. src_install() {
  121. rm nbbuild/build/javadoc/*.zip
  122. java-pkg_dojavadoc nbbuild/build/javadoc
  123. }