snip-0.11-r1.ebuild 724 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. DESCRIPTION="an Apache ANT optional task that extracts snippets of code from text files"
  7. HOMEPAGE="http://www.martiansoftware.com/lab/snip.html"
  8. SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.zip -> ${P}.zip"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
  12. IUSE=""
  13. CDEPEND="dev-java/ant-core:0"
  14. RDEPEND="
  15. ${CDEPEND}
  16. >=virtual/jre-1.6"
  17. DEPEND="
  18. ${CDEPEND}
  19. >=virtual/jdk-1.6
  20. source? ( app-arch/zip )"
  21. JAVA_GENTOO_CLASSPATH="ant-core"
  22. java_prepare() {
  23. java-pkg_clean
  24. }