tomcat-native-1.2.10.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils java-pkg-2 java-ant-2
  5. DESCRIPTION="Native APR library for Tomcat"
  6. SLOT="0"
  7. SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
  8. HOMEPAGE="http://tomcat.apache.org/"
  9. KEYWORDS="~amd64 ~x86"
  10. LICENSE="Apache-2.0"
  11. IUSE="test"
  12. RDEPEND="dev-libs/apr:1
  13. dev-libs/openssl:=
  14. >=virtual/jre-1.7"
  15. DEPEND=">=virtual/jdk-1.7
  16. test? ( dev-java/ant-junit:0 )"
  17. S=${WORKDIR}/${P}-src
  18. src_configure(){
  19. cd native || die
  20. econf --with-apr=/usr/bin/apr-1-config \
  21. --with-ssl=/usr || die "Could not configure native sources"
  22. }
  23. src_compile() {
  24. eant jar -f build.xml
  25. cd native || die
  26. default
  27. }
  28. src_install() {
  29. java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
  30. cd native
  31. emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
  32. }
  33. src_test() {
  34. java-pkg-2_src_test
  35. }
  36. pkg_postinst() {
  37. elog
  38. elog " APR should be available with Tomcat, for more information"
  39. elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
  40. elog
  41. elog " Please report any bugs to https://bugs.gentoo.org/"
  42. elog
  43. }