touchgraph-graphlayout-1.22-r1.ebuild 639 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. JAVA_PKG_IUSE="doc source"
  5. inherit java-pkg-2 java-pkg-simple
  6. MY_PN="TGGraphLayout"
  7. DESCRIPTION="TouchGraph provides a set of interfaces for graph visualization"
  8. HOMEPAGE="http://touchgraph.sourceforge.net"
  9. SRC_URI="mirror://sourceforge/touchgraph/TGGL_${PV//./}_jre11.zip"
  10. LICENSE="Apache-1.1"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc64 x86"
  13. IUSE=""
  14. DEPEND=">=virtual/jdk-1.6"
  15. RDEPEND=">=virtual/jre-1.6"
  16. S="${WORKDIR}/${MY_PN}"
  17. JAVA_SRC_DIR="com"
  18. src_install() {
  19. java-pkg-simple_src_install
  20. dodoc "TGGL ReleaseNotes.txt"
  21. }