xjavac-20110814.ebuild 967 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit java-pkg-2 java-ant-2
  5. DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
  6. SRC_URI="mirror://gentoo/${P}.tar.gz"
  7. #Note that the tarball has xjavac-ibm-1_5.patch already applied (not in upstream)
  8. IUSE=""
  9. HOMEPAGE="http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/tools/src/XJavac.java"
  10. LICENSE="Apache-2.0"
  11. SLOT="1"
  12. KEYWORDS="amd64 ~arm ppc64 x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  13. DEPEND=">=virtual/jdk-1.4"
  14. RDEPEND=">=virtual/jdk-1.4
  15. >=dev-java/ant-core-1.7"
  16. java_prepare() {
  17. cp "${FILESDIR}/${PN}-20041208-build.xml" ./build.xml || die "failed to cp build.xml"
  18. }
  19. src_compile() {
  20. eant jar -Dclasspath=$(java-pkg_getjars ant-core)
  21. }
  22. src_install() {
  23. java-pkg_dojar dist/${PN}.jar
  24. }