xml-commons-external-1.3.04.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. JAVA_PKG_IUSE="doc source"
  4. inherit java-pkg-2 java-ant-2
  5. DESCRIPTION="An Apache-hosted set of externally-defined standards interfaces, namely DOM, SAX, and JAXP"
  6. HOMEPAGE="http://xml.apache.org/commons/"
  7. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  8. # upstream source tar.gz is missing build.xml and other stuff, so we get it like this
  9. # svn export http://svn.apache.org/repos/asf/xml/commons/tags/xml-commons-external-1_3_04/java/external/ xml-commons-external-1.3.04
  10. # tar cjf xml-commons-external-1.3.04.tar.bz2 xml-commons-external-1.3.04
  11. LICENSE="Apache-2.0"
  12. SLOT="1.3"
  13. KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  14. IUSE="doc source"
  15. DEPEND=">=virtual/jdk-1.3"
  16. RDEPEND=">=virtual/jre-1.3"
  17. src_install() {
  18. java-pkg_dojar build/xml-apis.jar build/xml-apis-ext.jar
  19. dodoc NOTICE README.* || die
  20. if use doc; then
  21. java-pkg_dojavadoc build/docs/javadoc
  22. java-pkg_dohtml -r build/docs/dom
  23. fi
  24. use source && java-pkg_dosrc src/javax src/org
  25. }